We have taken corrective action to address the SFTP issue and have not observed any errors since the update. We will continue to monitor SFTP connections. If you continue to have SFTP issues, please contact UHIN Support.
Posted Jun 29, 2026 - 16:45 MDT
Update
UHIN continues to experience an intermittent issue affecting SFTP connections. Customers may experience brief periods when sftp.uhin.org or uhin3.net is unavailable. If you are unable to connect, please try again after a few minutes.
We are actively working to resolve the issue and will provide updates by the end of each business day and as significant developments occur until the issue is resolved.
Posted Jun 29, 2026 - 12:26 MDT
Identified
UHIN is currently experiencing an intermittent issue affecting our SFTP connections starting 6/20/26. Customers may see very brief periods when sftp.uhin.org is unavailable. If you are unable to connect, please try again. We are currently working to resolve the issue.
Posted Jun 22, 2026 - 10:59 MDT
This incident affected: The CHIE Platform (Alerts - Delivered via SFTP, Data Feeds) and Clearinghouse Platform (Payer Network).